またまたサーバーを移転します

サーバーを借りているXServerさんから、無償でサーバーのアップグレードをするので、新しいサーバーで検証してくれとメールをいただき、現在検証中です。
新しい環境では、Apacheが2.0へアップグレードされており、phpもphp.iniで設定を変更できるようになりました。が…多難続きです。自由度が増えたことは良いのですが、それだけ自分で検証、設定をしなければなりません。
簡単に移行ができるだろうと思ったのですが、さにあらず。DBをバックアップして新環境でリストア。アプリもそのままコピーしてと作業を進めました。
MTにアクセスできない???


ちょうど3.3がリリースされたので、それを使うとアクセスできる。アップグレードが完了し、設定を変更していると、再びアップグレードの画面が出て…結局リストアしたDBを削除して、新規インストールするはめに。
この際と思い、テンプレートを3.3用のもの使い、修正中。とりあえず、既成のスタイルをかぶせて、デザインは後で変更しようと思っています。
osCommerceが動かない。これまた、新規インストールから始めて…新しいバージョンがリリースされているのですが、現バージョンを使用。なんせ、多くカスタマイズしているので、それを1からやり直すのは気が遠くなります。塩漬けです。
こちらの方は、リストアしたDBでそのまま使用でき、ファイル類もすべて上書きで無事使えることが分かりました。
来週中には、サーバーを切り替えます。

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です

*